I want to emphasize that it is sometimes better for your code (cleaner, smaller) when you provide default values, because then you do not have to check either. I want to get rid of the if then else hell. Yes you also could move the each inside the if, but I want to get rid of the if. A default value should also be possible.

Developer since the 80'th, working at Forschungszentrum Jülich (http://www.fz-juelich.de) …

Get the Medium app

A button that says 'Download on the App Store', and if clicked it will lead you to the iOS App store
A button that says 'Get it on, Google Play', and if clicked it will lead you to the Google Play store